All known issues with broken links for Fluke Calibration software downloads have been resolved. We will continue to monitor for additional reports.
The knowledge base article for MET/SUPPORT Gold registration (https://my.fluke.com/en-us/article/KA-03972) has been updated to reflect the new steps for this process. Existing Gold registrations should be automatically migrated to the new system by the end of this week. The PIN required for new user registrations for existing Gold contracts can be obtained from Technical Support at softwaresupport@flukecal.com, but we are working on sending out this information proactively as well.
Posted Nov 15, 2024 - 15:27 UTC
Update
Some download links on the Fluke website are still broken at this time.
The knowledge base article for MET/SUPPORT Gold registration (https://my.fluke.com/en-us/article/KA-03972) has been updated to reflect the new steps for this process. Existing Gold registrations should be automatically migrated to the new system by the end of this week. The PIN required for new user registrations for existing Gold contracts can be obtained from Technical Support at softwaresupport@flukecal.com, but we are working on sending out this information proactively as well.
Posted Nov 14, 2024 - 21:22 UTC
Identified
Updating to correct status.
Posted Nov 11, 2024 - 23:58 UTC
Monitoring
Earlier today, the Fluke Calibration website at flukecal.com was redirected to the newly combined site at fluke.com. This impacted access to the latest release of MET/CONNECT and MET/CAL. While we work on migrating the pages for the latest release, they can be acquired by contacting technical support softwaresupport@flukecal.com
Additionally, MET/SUPPORT Gold registration is currently unavailable. An updated knowledge base article will be published with the new process for this shortly, and existing members will have their data migrated.